Chapter 5. MagicQ Layout

5.1. Physical layout

All MagicQ consoles are very similar - they differ mainly in the number of playback faders. The programming interface is consistent across the entire range of consoles. MagicQ software on PC and Mac mimics the layout of the physical buttons on the MagicQ Consoles - a choice of different Panels is available from the Panel Menu. The Full Panel mode mimics Pro and Compact whilst the Stadium Panem mode mimics the MQ500. It is possible to change between different panel views at any time - it does not affect the programmed show - it just determines what buttons, faders and encoders are available for programming and playback.

image

5.1.1. Touch Screen, Encoders & Soft Buttons

There are 8 rotary encoders placed around the main touch screen.

The buttons around around the top and sides of the display referred to as soft buttons since their function changes according to the active window on the touch screen. The current function of a soft button is displayed on the touch screen. To select the function you can either press the screen or the soft button itself next to the screen, depending on the consoe model

image

The function of the rotary encoders also changes according to the active window with the current function being displayed adjacent to the encoder.

There are ALT, SHIFT and CTRL buttons.

SHIFT is used for extra MagicQ programming functions.

CTRL is used for console settings such as setting screen brightness, console lamp brightness.

ALT is used to select alternative functions on MagicQ consoles that do not have a physical button for the particular function - the ALT function of a button is normally labelled on the panel.

5.1.2. Main Windows

The area in the centre of the screen is the windows section in which the various control windows are displayed. There are two main types of windows – boxes style windows which have large boxes such as the Group Window and spreadsheet style editing windows such as the Patch Window.

image

A window is displayed by pressing the appropriate window button. On MagicQ PC/Mac the window can be selected from the Window Menu from the toolbar. Changing window does not affect programming or playback.

Multiple windows can be displayed at one time by sizing and positioning the windows appropriately by clicking on the window title bar or using the SIZE button. On MagicQ PC/Mac the size and position can also be selected from the View Menu from the toolbar.

image

In addition a complete configuration of windows – i.e. a complete layout can be selected using the Layout buttons - to select the Palettes layout (Groups, Positions, Colours and Beams) press the Layout 1 button.

On the MQ500 the layout buttons are on the left side of the main touch screen. On Compact consoles there are physical Layout 1, Layout 2 and Layout 3 buttons by the keypad. On these consoles SHIFT + Layout 1 gets Layout 4, SHIFT + Layout 2 gets Layout 5 and SHIFT + Layout 3 gets Layout 6.

image

When a window button is pressed, that window becomes the active window. The active window is on the top of the screen and is easily identified as the window with the highlighted title bar at the top. It is also the window with the cursor in it.

An item in a window can be selected either

  1. By pressing the touch screen over the appropriate part of the window
  2. By moving the cursor to the appropriate position and pressing the ENTER button.
  3. By moving the mouse to the position and pressing the left mouse button.

The cursor can be moved around the active window using the cursor keys in the Editor area of the console or via the cursor keys on the keyboard. PG UP, PG DN, PG LEFT and PG RIGHT can be used to scroll the window in the appropriate direction. HOME and END can be used to get to the start and end of the window respectively.

On Compact consoles some window buttons and cursor buttons are accessed using the ALT button. PG UP, PG DN, PG LEFT and PG RIGHT use ALT and the cursor keys. HOME and END use ALT and LAYOUT 1 and LAYOUT 3 respectively.

On PC/Mac the contents of a Window can be printed to a printer or pdf file by selecting File, Print Window from the toolbar.

Window Sizing

From v1.4.8.0 MagicQ now supports a Window Size dialogue box to enable the window position and window size to be selected directly with one press directly rather than stepping through all the possible window sizes and postions.

The window size dialog box can also be opened by double clicking on the titlebar of the window that you wish to size. On MagicQ consoles the window size button SIZE (ALT EXEC on MQ40/60/80 and ALT PATCH on MQ500) opens the Window Size dialog box.

The old style window positioning and sizing is still available by pressing SHIFT + SIZE. Previously SHIFT + SIZE made a window external - but this has not been needed for many years as MAgicQ has had a dedicated EXT button.

MagicQ allows sizing of windows to 1,2 or 3 rows when using the LEFT (1..4) and RIGHT (1..4) window sizes. By default they continue to size as before - filling the left or right side automatically, but you can now specify for each window whether they should be restricted to 1,2 or 3 rows.

If you only have LEFT (1..4) windows opened then they will automatically spread across the whole width - so this new option is available on the left column, on the right column or across the whole width.

When you set a window to size of LEFT (1..4) or RIGHT (1..4) then you get extra options in the Toolbar, View menu to select the number of rows; Default, 1 row, 2 row, 3 row.

The setting is stored/recalled in Layouts and also in the show file.

Support for Find in MagicQ windows

MagicQ supports a Find function which searches the text fields in the current focused Window.

On the toolbar select Edit, Find or press the short cut key CTRL F. Alternatively on consoles press CTRL and CURSOR RIGHT. Then enter the text to search for. The find can also be invoked by entering text on the command line and then using any of the previous methods to start the Find operation.

To search again forwards press CTRL and CURSOR RIGHT. To search again backwards press CTRL and CURSOR LEFT.

The CTRL F shortcut only works on PC/Macs when MagicQ Keyboard Mode is set to Normal. In all other MagicQ Keyboard Modes the CTRL and keyboard keys open MagicQ windows.

5.1.3. Status and Display Windows

image

Towards the bottom of the touch screen are two small windows, the Status Display and the Input Display. The Status Display shows the current date and time, the ADD / SWAP status of the console and other relevant status information.

The status window also shows warnings - for example if INVALID NET is seen here this indicates MagicQ has been setup to output via Network e.g. Artnet and that MagicQ’s IP address has been set differently to the PC’s network adapter.

image

The Input Display shows the data that has been currently entered through the keypad and the keyboard. Note that text is not entered into the main Windows until ENTER is pressed. This allows the user to choose whether the keyboard data is SET into fields in the windows or onto Playbacks.

image

After a command has been entered it also confirms that the command has been accepted and shows any error messages when a command is not possible.

5.1.4. Head Control

The area around the two large rotary encoders is referred to as the head control area. It is used to alter the parameters of individual heads and apply effects such as fans over groups of heads.

image

The NEXT HEAD and PREV HEAD buttons are used to select an individual head to modify.

The other buttons control the selection mode; LOCATE, HIGHLIGHT, FAN, SINGLE, ODD/EVEN, and ALL.

5.1.5. Editor Buttons

image

The Editor buttons are used to modify program data. The 8 buttons on the right hand side are the action buttons which are used to modify show data. The action buttons are UNDO, REMOVE, MOVE, COPY, SET, INCLUDE, UPDATE, and RECORD.

The buttons on the left:

BLIND and CLEAR affect the programmer

REL and SELECT affect playbacks

SHIFT selects alternate functions

←- undoes keyboard input and clears actions

5.1.6. Playback

The Playback area is situated directly below the touch screen and consists of 10 playbacks each with a fader and four buttons (FLASH, GO, STOP, SELECT). The area above each of the playbacks on the touch screen is used to provide information about the status of the playback.

image

The playback area also contains a Grand Master, a Sub Master, Page Select buttons and a Manual Playback for taking control of Cue Stacks.

The cross fade section contains a GO, STOP. FWD, BCK buttons, a cross fader and a master GO button. The cross fade section controls the current playback selected with the S button.

On the MQ500 there are 15 fader playbacks and 15 execute playbacks above them.

5.2. Keyboard, Keypad, Select & Confirm Windows

MagicQ has a set of additional on-screen Windows that can be used to enter text, select items and confirm actions. You can choose whether you use the physical keyboard/keypad to navigate around these items or whether you use the mouse/touch.

To open the Keyboard Window at any time press SET SET. To open the icon selector press SHIFT + SET.

Confirm Windows are shown when you carry out important actions that may overwrite or delete show data. You can confirm an action by pressing 1 on the keypad. To cancel the action press 0 on the keypad.

5.3. Common Actions

MagicQ utilises many common actions for carrying out programming functions. All the actions use similar button presses. Once you understand the action in one Window, you will understand how it is done in another Window.

We strongly recommend you make yourself familiar with these actions – they will save you valuable programming time.

5.3.1. Items

Actions in a Window can be carried out on individual items or on multiple items. For actions on a single item, use the cursor keys to move around the Window so that the cursor is over the required item.

For multiple items in a Window, move the cursor to the first item. Then press and hold the SHIFT button whilst moving the cursor to the last item. All the items will be highlighted.

Alternatively hold the CTRL button and select multiple individual items.

In spreadsheet style Windows (e.g. Patch) pressing the touch screen or left clicking on the item with the mouse moves the cursor to the item. You can highlight multiple Window items by pressing the touch screen and moving the touch across multiple items.

In boxes style Windows (e.g. Group), pressing the touch screen or left clicking performs the function associated with the item (e.g. recalls that Group). In these Windows use SHIFT or CTRL and the cursor keys to highlight multiple boxes.

5.3.2. Setting the value of items

To set the value of one or more items in a spreadsheet style window:

  • Move the cursor over the item (s)
  • Enter a value on the keypad and press ENTER.

OR

  • Type in the value on the keypad
  • Press the touch screen / click / ENTER over the item.

For items that have a simple value of yes or no if you do not enter a value on the keypad then the value will toggle. For items that have multiple values double click on the field for a list of values. On the touch screen select the field and then press anywhere in the Input Display (right side area underneath the main window) to bring up the list of values.

Items that are coloured darker are read only and therefore cannot be set.

5.3.3. Naming items

  • Press the SET button
  • Press the touch screen / click / ENTER over the item to name.
  • Enter the name on the external or on screen keyboards

When working in spreadsheets style windows with an external keyboard it is not necessary to press the SET button in the above sequence - you can edit the spreadsheet like any other, just by moving to the appropriate box and entering text on the keyboard.

To name multiple items it is often easier to highlight the items before pressing SET. If you press SET immediately after highlighting multiple items then the console will assume that these are the items you wish to set.

You can also press SET instead of pressing ENTER in the above sequences.

5.3.4. Moving items

  • Press the MOVE button.
  • Press the touch screen / click / ENTER over the source item.
  • Press the touch screen / click / ENTER over the destination item.

You can also press MOVE instead of pressing ENTER in the above sequences.

To move multiple items it is often easier to highlight the items before pressing MOVE. If you press MOVE immediately after highlighting multiple items then the console will assume that these are the source items and will only prompt for the destination. You can hold SHIFT or CTRL to highlight multiple items.

From 1.7.6.4 MagicQ supports dragging to move items within Windows. Press SHIFT + MOVE to enter Drag Move mode. Items can then be dragged and dropped within windows. Drag Move mode will contirnue until MOVE is pressed again, or BACKSPACE is pressed.

The MOVE button flashes when in Drag Move mode.

5.3.5. Copying items

  • Press the COPY button.
  • Press the touch screen / click / ENTER over the source item.
  • Press the touch screen / click / ENTER over the destination item.

You can also press COPY instead of pressing ENTER in the above sequence.

To copy multiple items highlight it is often easier to highlight the items before pressing COPY. If you press COPY immediately after highlighting multiple items then the console will assume that these are the source items and will only prompt for the destination. You can hold SHIFT or CTRL to highlight multiple items.

When copying Cues, Cue Stacks or Pages the console by default does not make individual copies of the Cues - the Cue Stacks link to the same Cues. To copy unlinked (i.e. to create new Cues) then press SHIFT and COPY in the above sequence and select Unlinked.

5.3.6. Removing items

  • Press the REMOVE button.
  • Press the touch screen / click / ENTER over the item to remove.

To remove multiple items highlight it is often easier to highlight the items before pressing REMOVE. If you press REMOVE immediately after highlighting multiple items then the console will assume that you wish to remove the highlighted items.

You can also press REMOVE instead of pressing ENTER in the above sequence.

5.3.7. Recording items

In boxes style windows it is possible to record an item (e.g. in the Group Window, to record a group):

  • Press the RECORD button.
  • Press the touch screen / click / ENTER over the item to record.

You can also press RECORD instead of pressing ENTER in the above sequence.

5.4. Icons

MagicQ supports icons for all programmed items. The size of the icons can be set in the Window Settings in the Setup Window.

Icons can be used on Groups, Colours, Beams, Positions, Cues, Cue Stacks and in the Execute Window.

To set an icon for a Window item (e.g. a Palette Entry) press SHIFT SET. Press the touch screen / click / ENTER over the item to set an icon for. This will open the Icon library. The Icon library is split into different types of Icons for colours, positions and different types of gobos.

Select the icon from the icon library.

5.4.1. Actions on Playbacks

Actions on playbacks are similar to window items except that the S buttons are used instead of window items.

To select a Playback, press the S button for the appropriate Playback.

To record a Playback, press RECORD, then press the S button for the appropriate Playback.

To name a Playback press SET, then press the S button for the Playback. Enter the name using the on screen keyboard or the external keyboard.

To move a Playback, press MOVE, then press the S button for the source Playback and then press the S button for the destination Playback.

To copy a Playback, press COPY, then press the S button for the source Playback and then press the S button for the destination Playback.

To include the contents of a Playback into the Programmer, press INCLUDE, then press the S button for the destination Playback.

To remove a Playback, press REMOVE, then press the S button for the Playback. Press the S button again to confirm the remove.